让Apache支持ASP.NET
本文最后更新于 5775 天前,其中的信息可能已经有所发展或是发生改变。

今日偶然之间发现了这个Apache的mod_aspdotnet项目,发现Apache居然也可以支持ASP.NET。

据说由于IIS和Apache下的ASP.NET都是运行在Common Language Runtime(CRL)的基础上,因此Apache环境下的ASP.NET程序的运行速度不会比在IIS下慢。

而且使用mod_aspdotnet的时候首先,必须要有Windows环境和.NET Framework的支持。此外还建议安装.NET开发工具如.NET Framework SDK或者VisualStudio.NET。需要注意的是Windows的版本应为2000、2003和XP。Win9X系列不能安装.NET Framework。然后需要安装Apache。应该使用Win32平台的Apache,版本2.0以上。

不过查看了apache官方的介绍之后,伤心的发现这个项目居然已经从Apache官方去除了。按照Apache官方的说法:The mod_aspdotnet module has been retired by the httpd project. Every ASF project requires multiple developers, and this project did not have enough developers participating to remain under the ASF umbrella. Development has been resumed by the original authors at it's new home, the mod-aspdotnet SourceForge project. Note there is NO further support or effort on this module from the httpd project, refer all questions on to the SourceForge project's user and development lists.这段文字的大概意思就是由于mod_aspdotnet这个项目参与维护的人数和更新的周期导致此项目目前已经被去除,只能有sourceforge上的相关人员自行开发和维护了。

评论

  1. 啦啦啦
    16年前
    2008-5-09 10:24:14

    沙让Apache支持ASP.NET的发!!!

  2. Tommy
    16年前
    2008-5-09 17:43:34

    鸡肋。。。

  3. 博主
    16年前
    2008-5-10 0:31:49

    @Tommy 这个模块确实是没啥子用

  4. 16年前
    2008-5-11 23:14:15

    就是说.net现在实现了使用上的跨平台,但是运行平台上还是做不到啊。。
    悲剧~微软速速把apache收购了吧

  5. 博主
    16年前
    2008-5-12 1:38:59

    @Bighead Apache赶快把微软收购了吧

发送评论 编辑评论


				
|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇